Error while Opening AX 2012 R2 Retail POS: could not load all external service modules

It is a common error for AX 2012 R2 POS screen, whenever we setup device information on hardware profile and run the N-jobs, this error usually appears on POS screen and it won’t let you open POS.


 

Connector TestConnector not found!

SystemCore: System.Exception: Processor not found.
at Microsoft.Dynamics.Retail.SDKManager.PaymentProcessorManager.GetPaymentProcessor(String name)
at Microsoft.Dynamics.Retail.Pos.EFT.PaymentSDKProcessor.GetEftPaymentProcessor(String connectorName)
at Microsoft.Dynamics.Retail.Pos.EFT.PaymentSDKProcessor.GetEftProcessorServices(String connectorName)
at Microsoft.Dynamics.Retail.Pos.EFT.EFT.Initialize()
at Microsoft.Dynamics.Retail.Pos.SystemCore.Services.Initialize()
at Microsoft.Dynamics.Retail.Pos.SystemCore.PosApplication.Initialize().


 

The solution I found is simple by copying TestConnector DLL to Retail folder.

1. Copy the Microsoft.Dynamics.Retail.TestConnector.dll from “C:\Program Files (x86)\Microsoft Dynamics AX\60\Client\Bin\Connectors”

2. Paste the Microsoft.Dynamics.Retail.TestConnector.dll to “C:\Program Files (x86)\Microsoft Dynamics AX\60\Retail POS\Connectors”

3. Open POS, Problem solved

 

Leave a Comment

Name (required)
Email (required)
Comment (required)

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>